fbpx

Use Hangouts Meet with Internet Explorer 11

Use Hangouts Meet with Internet Explorer 112019-12-09T13:02:20+00:00

Project Description

📖 < 1 min read

Quick launch summary

Google has added limited Hangouts Meet support in Microsoft Internet Explorer 11. You’ll need to download and install the latest version of the Google Video Support Plugin for Meet to run on Internet Explorer.

Please check Google’s Help Center to learn more about supported browsers and some of the limitations of using Hangouts Meet with Internet Explorer.

Availability

Rollout details

Google Workspace editions

  • Available to all Google Workspace editions

On/off by default?

  • This feature will be OFF by default. Please download the plugin to use Meet with Internet Explorer.
Thanks for sharing and spreading the word!
Go to Top